Commit e306653d authored by Casey Faist's avatar Casey Faist

don't update after installing pipenv

parent d3180d32
# Python Buildpack Changelog # Python Buildpack Changelog
# 139 # 140 (2018-10-X)
Add an `OVERRIDDEN_PIPENV_VERSION` option to override the version of Pipenv
used in the buildpack
Upgrade the `DEFAULT_PIPENV_VERSION` to `2018.7.1`
# 139 (2018-10-8)
Improvements to Python install messaging Improvements to Python install messaging
......
...@@ -9,14 +9,11 @@ set -e ...@@ -9,14 +9,11 @@ set -e
if [[ -f Pipfile.lock ]]; then if [[ -f Pipfile.lock ]]; then
if [[ -f .heroku/python/Pipfile.lock.sha256 ]]; then if [[ -f .heroku/python/Pipfile.lock.sha256 ]]; then
if [[ $(openssl dgst -sha256 Pipfile.lock) == $(cat .heroku/python/Pipfile.lock.sha256) ]]; then if [[ $(openssl dgst -sha256 Pipfile.lock) == $(cat .heroku/python/Pipfile.lock.sha256) ]]; then
# Measure that we're using Pipenv.
mcount "tool.pipenv"
# Don't skip installation of there are git deps. # Don't skip installation of there are git deps.
if ! grep -q 'git' Pipfile.lock; then if ! grep -q 'git' Pipfile.lock; then
echo "Skipping installation, as Pipfile.lock hasn't changed since last deploy." | indent echo "Skipping installation, as Pipfile.lock hasn't changed since last deploy." | indent
mcount "tool.pipenv"
export SKIP_PIPENV_INSTALL=1 export SKIP_PIPENV_INSTALL=1
export SKIP_PIP_INSTALL=1 export SKIP_PIP_INSTALL=1
fi fi
...@@ -29,8 +26,6 @@ fi ...@@ -29,8 +26,6 @@ fi
if [ ! "$SKIP_PIPENV_INSTALL" ]; then if [ ! "$SKIP_PIPENV_INSTALL" ]; then
# Pipenv support (Generate requriements.txt with pipenv). # Pipenv support (Generate requriements.txt with pipenv).
if [[ -f Pipfile ]]; then if [[ -f Pipfile ]]; then
# Measure that we're using Pipenv.
mcount "tool.pipenv"
# Skip pip install, later. # Skip pip install, later.
export SKIP_PIP_INSTALL=1 export SKIP_PIP_INSTALL=1
...@@ -41,10 +36,10 @@ if [ ! "$SKIP_PIPENV_INSTALL" ]; then ...@@ -41,10 +36,10 @@ if [ ! "$SKIP_PIPENV_INSTALL" ]; then
export PIP_EXTRA_INDEX_URL export PIP_EXTRA_INDEX_URL
fi fi
export PIPENV_VERSION="2018.5.18" export DEFAULT_PIPENV_VERSION="2018.7.1"
# Install pipenv. # Install pipenv; do not upgrade.
/app/.heroku/python/bin/pip install pipenv==$PIPENV_VERSION --upgrade &> /dev/null /app/.heroku/python/bin/pip install pipenv==$PIPENV_VERSION &> /dev/null
# Install the dependencies. # Install the dependencies.
if [[ ! -f Pipfile.lock ]]; then if [[ ! -f Pipfile.lock ]]; then
...@@ -59,6 +54,8 @@ if [ ! "$SKIP_PIPENV_INSTALL" ]; then ...@@ -59,6 +54,8 @@ if [ ! "$SKIP_PIPENV_INSTALL" ]; then
puts-step "Installing dependencies with Pipenv $PIPENV_VERSION…" puts-step "Installing dependencies with Pipenv $PIPENV_VERSION…"
/app/.heroku/python/bin/pipenv install --system --deploy 2>&1 | indent /app/.heroku/python/bin/pipenv install --system --deploy 2>&1 | indent
fi fi
# Measure that we're using Pipenv.
mcount "tool.pipenv"
# Install the test dependencies, for CI. # Install the test dependencies, for CI.
if [ "$INSTALL_TEST" ]; then if [ "$INSTALL_TEST" ]; then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment